Network RFC Docs Analyze

BGP Next-Hop-Self 테스트

Lewis Joo 2023. 6. 20.

 

iBGP의 한 가지 잠재적인 문제는 다음 홉 IP 주소를 변경하지 않는다는 것입니다 .

 

대표사진 삭제

사진 설명을 입력하세요.

R1>#
interface Ethernet2
   no switchport
   ip address 192.168.12.1/24
ip routing
!
router bgp 12
   neighbor 192.168.12.2 remote-as 12
   neighbor 192.168.12.2 maximum-routes 12000
 
R2>#
interface Ethernet1
   no switchport
   ip address 192.168.23.2/24
!
interface Ethernet2
   no switchport
   ip address 192.168.12.2/24
!

ip routing
!
router bgp 12
   neighbor 192.168.12.1 remote-as 12
   neighbor 192.168.12.1 maximum-routes 12000
   neighbor 192.168.23.3 remote-as 3
   neighbor 192.168.23.3 maximum-routes 12000
 
R3>#
interface Ethernet1
   no switchport
   ip address 192.168.23.3/24
!
interface Loopback0
   ip address 3.3.3.1/24
!
ip routing
!
router bgp 3
   neighbor 192.168.23.2 remote-as 12
   neighbor 192.168.23.2 maximum-routes 12000
   network 3.3.3.0/24
 

<결과>

R2(config-router-bgp)#show ip bgp
BGP routing table information for VRF default
Router identifier 192.168.23.2, local AS number 12
Route status codes: s - suppressed, * - valid, > - active, E - ECMP head, e - ECMP
                    S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
                    % - Pending BGP convergence
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI Origin Validation codes: V - valid, I - invalid, U - unknown
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop

          Network                Next Hop              Metric  AIGP       LocPref Weight  Path
 * >      3.3.3.0/24             192.168.23.3          0       -          100     0       3 i
 
R1#show ip bgp
BGP routing table information for VRF default
Router identifier 192.168.12.1, local AS number 12
Route status codes: s - suppressed, * - valid, > - active, E - ECMP head, e - ECMP
                    S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
                    % - Pending BGP convergence
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI Origin Validation codes: V - valid, I - invalid, U - unknown
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop

          Network                Next Hop              Metric  AIGP       LocPref Weight  Path
          3.3.3.0/24             192.168.23.3          0       -          100     0       3 i
R1#
 

R1에서 3.3.3.0/24 대역에대한 정보가 NEXT HOP이 바뀌지않고 그대로 192.168.23.3을 가져온다.

 

R2(config-router-bgp)#neighbor 192.168.12.1 next-hop-self
 

NEXT-HOP-SELF명령어를 적용하면 NEXT-HOP이 바뀐다.

R1#show ip bgp
BGP routing table information for VRF default
Router identifier 192.168.12.1, local AS number 12
Route status codes: s - suppressed, * - valid, > - active, E - ECMP head, e - ECMP
                    S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
                    % - Pending BGP convergence
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI Origin Validation codes: V - valid, I - invalid, U - unknown
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop

          Network                Next Hop              Metric  AIGP       LocPref Weight  Path
 * >      3.3.3.0/24             192.168.12.2          0       -          100     0       3 i
R1#
 

R1에서 NEXT_HOP이 192.168.12.2 로 변경된 모습.

 

 

또는 NETWORK정보를 광고하는 방법도 있다.

아래처럼 NETWORK 를 광고하자.

R2(config-router-bgp)#network 192.168.23.0/24
 

 

R1#show ip bgp
BGP routing table information for VRF default
Router identifier 192.168.12.1, local AS number 12
Route status codes: s - suppressed, * - valid, > - active, E - ECMP head, e - ECMP
                    S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
                    % - Pending BGP convergence
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI Origin Validation codes: V - valid, I - invalid, U - unknown
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop

          Network                Next Hop              Metric  AIGP       LocPref Weight  Path
 * >      3.3.3.0/24             192.168.23.3          0       -          100     0       3 i
 * >      192.168.23.0/24        192.168.12.2          0       -          100     0       i
R1#
 

192.168.23.3 넥스트홉은그대로지만

그 홉에대한 NEXT_HOP이 192.168.12.2로서 추가된 모습.

 

 

정리.

 

중간자에서

neighbor #IP# next-hop-self를 써도되고

network로 next-hop을 광고해도 된다.

iBGP는 next-hop을 그대로 넘기기 때문에 위 솔루션을 사용한다.

 

반응형

'Network RFC Docs Analyze' 카테고리의 다른 글

네트워크 기초 정리자료#1  (0) 2023.06.28
Loopback을 이용한 BGP간 네이버 설정  (0) 2023.06.27
IBGP 특징 & Route-Reflector  (0) 2023.06.27
Floating Static Route  (0) 2023.06.21
MP-BGP 지원 프로토콜  (0) 2023.06.21

댓글